<!DOCTYPE html>
<html lang="en-US">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://eritreahub.org/xmlrpc.php">

<title>Isaias’s holocaust moment: The threat of mass deaths in SAWA camp - Eritrea Hub</title>

<!-- This site is optimized with the Yoast SEO plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Isaias’s holocaust moment: The threat of mass deaths in SAWA camp - Eritrea Hub" />
<meta property="og:description" content="Source: Assenna Isaias’s holocaust moment:  The threat of mass deaths in SAWA camp By Petros Tesfagiogis Human crisis is looming..." />
<meta property="og:url" content="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp" />
<meta property="og:site_name" content="Eritrea Hub" />
<meta property="article:tag" content="COVID19" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-04-04T13:14:23+00:00" />
<meta property="og:image" content="https://i2.wp.com/eritreahub.org/wp-content/uploads/2020/03/Sawa-Eritrea.jpg?fit=840%2C450&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/eritreahub.org/wp-content/uploads/2020/03/Sawa-Eritrea.jpg?fit=840%2C450&#038;ssl=1" />
<meta property="og:image:width" content="840" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Source: Assenna Isaias’s holocaust moment:  The threat of mass deaths in SAWA camp By Petros Tesfagiogis Human crisis is looming..." />
<meta name="twitter:title" content="Isaias’s holocaust moment: The threat of mass deaths in SAWA camp - Eritrea Hub" />
<meta name="twitter:image" content="https://i2.wp.com/eritreahub.org/wp-content/uploads/2020/03/Sawa-Eritrea.jpg?fit=840%2C450&#038;ssl=1" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://eritreahub.org/#website","url":"https://eritreahub.org/","name":"Eritrea Hub","inLanguage":"en-US","description":"Information about Eritrea and the Horn of Africa","potentialAction":{"@type":"SearchAction","target":"https://eritreahub.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/eritreahub.org/wp-content/uploads/2020/03/Sawa-Eritrea.jpg?fit=840%2C450&ssl=1","width":840,"height":450},{"@type":"WebPage","@id":"https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp#webpage","url":"https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp","name":"Isaias\u2019s holocaust moment: The threat of mass deaths in SAWA camp - Eritrea Hub","isPartOf":{"@id":"https://eritreahub.org/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp#primaryimage"},"datePublished":"2020-04-04T13:14:23+00:00","dateModified":"2020-04-04T13:14:23+00:00","author":{"@id":"https://eritreahub.org/#/schema/person/f8aa467e7efa6ad219dee345cc901ee5"}},{"@type":["Person"],"@id":"https://eritreahub.org/#/schema/person/f8aa467e7efa6ad219dee345cc901ee5","name":"Eritrea Hub","image":{"@type":"ImageObject","@id":"https://eritreahub.org/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/f500be2fede3974a790a653d590103bc?s=96&d=mm&r=g","caption":"Eritrea Hub"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; Feed" href="https://eritreahub.org/feed" />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; Comments Feed" href="https://eritreahub.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; Isaias’s holocaust moment: The threat of mass deaths in SAWA camp Comments Feed" href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/eritreahub.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='poseidon-custom-fonts-css'  href='https://eritreahub.org/wp-content/themes/poseidon/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://eritreahub.org/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://eritreahub.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='poseidon-stylesheet-css'  href='https://eritreahub.org/wp-content/themes/poseidon/style.css?ver=1.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://eritreahub.org/wp-content/themes/poseidon/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/navigation.js?ver=20170127'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/sticky-header.js?ver=20170203'></script>
<link rel='https://api.w.org/' href='https://eritreahub.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://eritreahub.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://eritreahub.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p9mKWT-104' />
<link rel="alternate" type="application/json+oembed" href="https://eritreahub.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feritreahub.org%2Fisaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp" />
<link rel="alternate" type="text/xml+oembed" href="https://eritreahub.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feritreahub.org%2Fisaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.
Click the help icon above to learn more.
*/

p.site-description {}

@media only screen  and (max-width : 1224px) {
p.site-description {max-width:12em;}
}			</style>
		</head>

<body class="post-template-default single single-post postid-3848 single-format-standard wp-embed-responsive">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="https://eritreahub.org/" rel="home">Eritrea Hub</a></p>

							
			<p class="site-description">Information about Eritrea and the Horn of Africa</p>

		
				</div><!-- .site-branding -->

				<nav id="main-navigation" class="primary-navigation navigation clearfix" role="navigation">
					<ul id="menu-primary-nav" class="main-navigation-menu"><li id="menu-item-181" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181"><a href="https://eritreahub.org/category/news">News</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31"><a href="https://eritreahub.org/category/research-information">Research &#038; information</a>
<ul class="sub-menu">
	<li id="menu-item-87" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87"><a href="https://eritreahub.org/category/research-information/eu">EU</a></li>
	<li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88"><a href="https://eritreahub.org/category/research-information/africa">Africa</a></li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://eritreahub.org/category/maps-photography">Maps &#038; photography</a></li>
<li id="menu-item-53" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53"><a href="https://eritreahub.org/category/immigration-refugees">Immigration &#038; refugees</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://eritreahub.org/contact">Contact</a></li>
</ul>				</nav><!-- #main-navigation -->

			</div><!-- .header-main -->

		</header><!-- #masthead -->

		
		
		
		<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-3848" class="post-3848 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-covid19">

	
	<header class="entry-header">

		<h1 class="entry-title">Isaias’s holocaust moment: The threat of mass deaths in SAWA camp</h1>
		<div class="entry-meta"><span class="meta-date"><a href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp" title="1:14 pm" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T13:14:23+00:00">April 4, 2020</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://eritreahub.org/author/eritreahub" title="View all posts by Eritrea Hub" rel="author">Eritrea Hub</a></span></span><span class="meta-category"> <a href="https://eritreahub.org/category/news" rel="category tag">News</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<p>Source: <a href="https://assenna.com/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp/" target="_blank" rel="noopener noreferrer">Assenna</a></p>
<div class="edgtf-post-title-area">
<p class="edgtf-post-excerpt">Isaias’s holocaust moment:  The threat of mass deaths in SAWA camp By Petros Tesfagiogis Human crisis is looming large on the horizon because of the killer COVID-19 pandemic spreading all over the world.  Governments are issuing guidelines</p>
<div class="edgtf-post-info">
<div class="edgtf-post-info-date entry-date updated"> <a href="https://assenna.com/2020/04/">APRIL 3, 2020 </a></div>
<div class="edgtf-post-info-time"></div>
</div>
</div>
<div class="edgtf-post-image"><img class="attachment-magazinevibe_edge_post_feature_image size-magazinevibe_edge_post_feature_image wp-post-image" src="https://i1.wp.com/assenna.com/wp-content/uploads/2013/04/Water_asmera.jpg?resize=500%2C375&#038;ssl=1" sizes="(max-width: 500px) 100vw, 500px" srcset="https://i1.wp.com/assenna.com/wp-content/uploads/2013/04/Water_asmera.jpg?resize=500%2C375&#038;ssl=1 500w, https://assenna.com/wp-content/uploads/2013/04/Water_asmera-300x225.jpg 300w, https://assenna.com/wp-content/uploads/2013/04/Water_asmera-400x300.jpg 400w" alt="" width="500" height="375" data-recalc-dims="1" /></div>
<div class="edgtf-post-text">
<div class="edgtf-post-text-inner clearfix">
<p>Isaias’s holocaust moment:  The threat of mass deaths in SAWA camp</p>
<p><em>By Petros Tesfagiogis</em></p>
<p>Human crisis is looming large on the horizon because of the killer COVID-19 pandemic spreading all over the world.  Governments are issuing guidelines to their citizens to stay put in their houses to avoid the spread the virus to the public.  People leaving their houses are advised to keep their distance from other people and avoid shaking hands.   Governments are closing schools and churches and mosques. This is a global guideline and all governments are duty bound to follow it.</p>
<p>The Regime in Eritrea did not adhere to the guidelines and has not closed the most crowded place in the country, the high school and national service training centre in SAWA.  In Sawa, every year thousands of students gather to complete their 12<sup>th</sup> grade, the school leaving year.  After finishing their studies, they are made to stay there to do military training and continue to serve in the indefinite national service, widely known as forced/ slave labour.  They are assingned to work in different fields or kept as foot soldiers in the trenches to defend the country, mainly from the threat of Ethiopian invasion. It is an excuse to hold hostage the youth so they will not oppose the gross human rights violations in Eritrea for the same reason that the regime closed the only university in Eritrea. The indefinite national service policy has destroyed the future of the Eritrean youth and deprived the country of its most productive members of the society. It gave rise to the influx of huge number of refugees to exile.</p>
<p>As a priority, the Eritrean government should have sent all the occupants of the camp to their houses/families and not ignore the world wide expert advice for people to avoid any crowding or gatherings and stay isolated in their homes. Furthermore, the regime should have released all prisoners of conscience and those incarcerated for petty crimes to avoid the spread of the disease in the prisons. This is another evidence that Isaias does not care about the welfare of the Eritrean people.</p>
<p>The corona virus has already made it into Eritrea with passengers carrying the virus found on arrival at Asmara Airport and the number of cases is quickly spreading. The students in Sawa remain highly vulnerable and a single carrier could contaminate the entire camp and people could die in their thousands unless the necessary measures are taken urgently.  It could be a mayhem and a catastrophe of historical proportion. It will be the same for the prisoners of conscience and other prisoners dumped in 360 prisons around the country.</p>
<p>The spread of the disease in Sawa and the prisons will be Eritrea’s holocaust caused by Isaias’s arrogance and inaction. They are abandoned to die from the virus.  For the people of Eritrea this is not new.  A few months ago the regime closed 27 health centres that were run by the Catholic Church and used to serve more than 200,000 people a year. For Isaias, the lives of Eritreans are not a concern. He has subjected the entire population to gross human rights violations for years. All the violations are recorded by international human rights organisations such as Amnesty International, Human Rights Watch, Journalists Without Borders, Defend the Defenders and others and by various Eritrean human right activists. All these has given rise to protests, appeals and condemnations by Eritreans abroad.</p>
<p>The UN Commission of Inquiry on Eritrea’s report was a confirmation of what the humanitarian organisations the world over were saying. Presenting the findings in June 2015, Mike Smith the chairman of the UN inquiry commission said: “The many violations in Eritrea are of a scope and scale seldom seen anywhere else in today’s world. Basic freedoms are curtailed, from movement to expression; from religion to association. The commission finds that crimes against humanity may have been occurred with regard to torture, extrajudicial executions, forced labour and in the context of national service. “</p>
<p>Therefore, it is doubtful that the Government of Eritrea will seriously act to stop the spread of the Coronavirus. The guidelines it issued forbidding people to gather in groups of more than 10 people is a public relations exercise designed to mislead the population. Despite the much celebrated peace deal with Ethiopia, Isaias did not bother to release a single prisoner of conscience. He used the peace with Ethiopia to come out of international isolation and perpetuate repression. It is against the wish people of Eritrea who want a genuine peace with the people of Ethiopia. This was proved during the short time when the border with Ethiopia’s Tigray region was opened. No one could forget the joy and happiness expressed by the people from the border regions of Eritrea and Ethiopia. It was an unforgettable moment. But their jubilations were cut short as the border was closed soon by Isaias.</p>
<p>The Eritrean People have given up on Isaias. The justice seekers in Diaspora are rising up in masses and established powerful mass movements (YIAKL), saying ENOUGH, Isaias has to go. It started in Washington DC and spread to Europe, Canada, and Australia etc. In United Kingdom the Yiakl movement was also celebrated.  On March, Eritrean women from many states in USA held a successful conference in Washington DC and pledged to contribute to the struggle to get rid of Isaias. The Eritrean women in the United Kingdom did the same.  This shows that there is a noticeable growth in the confidence and determination among Eritrean women.</p>
<p>The Eritrean just seekers in diaspora are concerned about the corona virus and are trying to help.  The dilemma is that the regime cannot be trusted.  How can a regime that brought poverty and destitution to the population be trusted?  Isaias is corrupted by power and he is morally bankrupt and nothing good can be expected from him.  The only way for help is to come through the UN.</p>
<p>It has become apparent that the poor third world countries do not have the capacity and the resources to prevent the spread of the virus.  The Economist magazine predicts that COVID-19 would be much more devastating for the world’s poor countries were running water and basic medicine is still a luxury, let alone intensive care for hundreds of thousands of patients.</p>
<p>Ethiopian Prime Minister, Dr Abiy Ahmed has written to the world’s rich countries of the consequences of failing to help the poor counters to prevent the spread of Covid-19. The title of his article reads: “If Covid-19 is not beaten in Africa it will return to  haunt us all”. Advanced economies are unveiling unprecedented economic stimulus packages. African countries by contrast, lack the wherewithal to make meaningful interventions. Yet if the virus is not defeated in Africa, it could bounce back to the rest of the world.  He concluded “We can defeat this invisible and vicious adversary – but only with global leadership. This goes to show that there is a consensus the poor countries need help.</p>
<p><strong>In the case of Eritrea, is the Eritreans in Diaspora who must take the initiative to expose the Eritrea repressive regime. They must seek help for the people of Eritrea.</strong></p>
<p>What is encouraging is that Eritreans are showing concern and want to help. But many people are in a dilemma how can they trust the regime who has total grip on the people. For example, Awet T. Weldemichael, in his facebook page said the following: “Eritrea during this covid-19 pandemic. The country needs robust inter-ministerial task-force on covid-19, led by capable professionals. Composed of senior representatives of relevant ministries, the taskforce transparently. Without  such an accountable, transparent body, &amp; effectiveness and flexible policy framework informed with up-to-date science, no amount of resources will be adequate. Such a body and framework will give nationals the confidence to do their utmost.” He further put 6 points work and responsibility details.</p>
<p>This is well thought but the regime do not have the capacity and the manpower to do it. There is no functional ministry in the country. There are many capable Eritrean professionals abroad willing to go and help. But the regime does not welcome such Eritrean people and their safety would be in danger.</p>
<p>The only way is to campaign to have UN bodies to send volunteers to Eritrea to asses the needs and provide support. WHO (the world Health organisation) and UNESCO are already working in Eritrea.   The presence of the UN bodies to help in building the capacity and do the monitoring is crucial. Help could be requested from the Chinese who are offering help to both developed and developing in a big way.</p>
<p><strong>It is the Chinese who are sending ventilators and medical teams to Italy and face masks to Africa. A Chinese charity sent 300,000 face masks </strong><strong>to Belgium in a container on which was written the slogan “Unity Makes Strength” in French, Flemish and Chinese</strong><strong>.</strong><strong> </strong></p>
<p>The world would definitely respond to the plea of Eritreans in the diaspora and help Eritrea. But the just seekers must initiate a task-Force composed of professionals with a workable organisational structure that enables the various units to act in a centralized manner, with speed and effectiveness as the task-force will face unpredictable challenges. The Task force can use skype to engage in discussions clarify the objectives and the action plan. Then, they could formulate the request to put pressure to the regime so it sends home the occupants of SAWA and the 360 illegal prisons.</p>
<p>In this collective effort Eritrea Focus could contribute a lot. Through its persistent work it has many sympathisers in high government officials in UK, the States and in some European countries.</p>
<p>It has already sent a letter of protest to H. E  Dr Abiy Ahmed, Prime Minister of Ethiopia  not to  close the Hitsats  refugee camp were 18,000 Eritreans are languishing, with copies sent to local and international bodies in Europe, Ethiopia and Africa. It is also looking into ways to put in place  a watch dog on the situation of refugees and the risk of exposure to the corona virus.</p>
<p><strong>This not the time for complacency. Those of us who live in the democratic countries have to translate the slogan “We are the voice of the voiceless” into action.</strong><strong>          </strong></p>
<p>Diaspora Eritreans have a very challenging responsibility to expose the conspiracy of the dictator Isaias in his decision not to close Sawa and the illegal prisons.</p>
<p>&nbsp;</p>
<p>The end</p>
</div>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-3848" class="share-twitter sd-button share-icon" href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-3848" class="share-facebook sd-button share-icon" href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="https://eritreahub.org/tag/covid19" rel="tag">COVID19</a>				</span>
			</div><!-- .entry-tags -->

						
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://eritreahub.org/covid-19-supplies-from-chinese-billionaire-jack-ma-never-reached-eritrea" rel="prev"><span class="screen-reader-text">Previous Post:</span>COVID-19 supplies from Chinese billionaire Jack Ma never reached Eritrea</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://eritreahub.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3848' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="59433df0cf" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="117"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
		
		</main><!-- #main -->
	</section><!-- #primary -->
	
	
	<section id="secondary" class="sidebar widget-area clearfix" role="complementary">

		<aside id="categories-4" class="widget widget_categories clearfix"><div class="widget-header"><h3 class="widget-title">Categories</h3></div>		<ul>
				<li class="cat-item cat-item-244"><a href="https://eritreahub.org/category/ethiopia">Ethiopia</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://eritreahub.org/category/immigration-refugees">Immigration &amp; refugees</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://eritreahub.org/category/judicial-rulings">Judicial rulings</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://eritreahub.org/category/maps-photography">Maps &amp; photography</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://eritreahub.org/category/news">News</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://eritreahub.org/category/reports">Reports</a>
<ul class='children'>
	<li class="cat-item cat-item-38"><a href="https://eritreahub.org/category/reports/amnesty-international">Amnesty International</a>
</li>
	<li class="cat-item cat-item-577"><a href="https://eritreahub.org/category/reports/eritrea-focus">Eritrea Focus</a>
</li>
	<li class="cat-item cat-item-599"><a href="https://eritreahub.org/category/reports/ethiopia-insight">Ethiopia Insight</a>
</li>
	<li class="cat-item cat-item-237"><a href="https://eritreahub.org/category/reports/human-rights-watch">Human Rights Watch</a>
</li>
	<li class="cat-item cat-item-42"><a href="https://eritreahub.org/category/reports/institute-of-security-studies">Institute of Security Studies</a>
</li>
	<li class="cat-item cat-item-315"><a href="https://eritreahub.org/category/reports/parties">Parties</a>
</li>
	<li class="cat-item cat-item-86"><a href="https://eritreahub.org/category/reports/regional-mixed-migration-secretariat">Regional Mixed Migration Secretariat</a>
</li>
	<li class="cat-item cat-item-678"><a href="https://eritreahub.org/category/reports/uk-all-party-parliamentary-group">UK All Party Parliamentary Group</a>
</li>
	<li class="cat-item cat-item-186"><a href="https://eritreahub.org/category/reports/un-ocha">UN Ocha</a>
</li>
	<li class="cat-item cat-item-710"><a href="https://eritreahub.org/category/reports/unhcr">UNHCR</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://eritreahub.org/category/reports/united-nations-human-rights-commission">United Nations Human Rights Commission</a>
</li>
	<li class="cat-item cat-item-25"><a href="https://eritreahub.org/category/reports/united-nations-monitoring-group">United Nations Monitoring Group</a>
</li>
	<li class="cat-item cat-item-665"><a href="https://eritreahub.org/category/reports/us-state-department">US State Department</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-2"><a href="https://eritreahub.org/category/research-information">Research &amp; information</a>
<ul class='children'>
	<li class="cat-item cat-item-14"><a href="https://eritreahub.org/category/research-information/africa">Africa</a>
</li>
	<li class="cat-item cat-item-197"><a href="https://eritreahub.org/category/research-information/eritrea">Eritrea</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://eritreahub.org/category/research-information/eu">EU</a>
</li>
	<li class="cat-item cat-item-230"><a href="https://eritreahub.org/category/research-information/horn-of-africa">Horn of Africa</a>
</li>
	<li class="cat-item cat-item-422"><a href="https://eritreahub.org/category/research-information/international-crisis-group">International Crisis Group</a>
</li>
	<li class="cat-item cat-item-190"><a href="https://eritreahub.org/category/research-information/other">Other</a>
</li>
	<li class="cat-item cat-item-111"><a href="https://eritreahub.org/category/research-information/sudan">Sudan</a>
</li>
	<li class="cat-item cat-item-319"><a href="https://eritreahub.org/category/research-information/un">UN</a>
</li>
	<li class="cat-item cat-item-85"><a href="https://eritreahub.org/category/research-information/world-bank">World Bank</a>
</li>
	<li class="cat-item cat-item-77"><a href="https://eritreahub.org/category/research-information/yemen">Yemen</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-8"><a href="https://eritreahub.org/category/top-news">Top news</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://eritreahub.org/category/uncategorized">Uncategorized</a>
</li>
		</ul>
			</aside><aside id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget clearfix"><div class="widget-header"><h3 class="widget-title">Follow Blog via Email</h3></div>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Click to follow this blog and receive notifications of new posts by email.</p>
</div><p>Join 22,813 other subscribers</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-3"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Follow                        </button>
                    </p>
				            </form>
		
</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries clearfix">		<div class="widget-header"><h3 class="widget-title">Recent Posts</h3></div>		<ul>
											<li>
					<a href="https://eritreahub.org/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp" aria-current="page">Isaias’s holocaust moment: The threat of mass deaths in SAWA camp</a>
									</li>
											<li>
					<a href="https://eritreahub.org/covid-19-supplies-from-chinese-billionaire-jack-ma-never-reached-eritrea">COVID-19 supplies from Chinese billionaire Jack Ma never reached Eritrea</a>
									</li>
											<li>
					<a href="https://eritreahub.org/the-pope-appoints-a-new-ambassador-to-eritrea-and-sudan">The Pope appoints a new ambassador to Eritrea and Sudan</a>
									</li>
											<li>
					<a href="https://eritreahub.org/preventing-a-water-war-sudan-pm-to-restore-negotiations-on-ethiopia-dam">Preventing A Water War – Sudan PM To Restore Negotiations On Ethiopia Dam</a>
									</li>
											<li>
					<a href="https://eritreahub.org/eritrea-must-free-political-prisoners-and-low-risk-offenders-to-reduce-covid-19-threat-in-crowded-jails-says-un-expert">Eritrea must free political prisoners and low-risk offenders to reduce COVID-19 threat in crowded jails, says UN expert</a>
									</li>
					</ul>
		</aside><aside id="search-3" class="widget widget_search clearfix"><div class="widget-header"><h3 class="widget-title">Search</h3></div>
<form role="search" method="get" class="search-form" action="https://eritreahub.org/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
</form>
</aside>
	</section><!-- #secondary -->

	

	</div><!-- #content -->

	
	<div id="footer" class="footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			
			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		WordPress Theme: Poseidon by <a href="https://themezee.com/" target="_blank" rel="nofollow">ThemeZee</a>.	</span>

				</div><!-- .site-info -->

		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->

	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/eritreahub.org\/isaiass-holocaust-moment-the-threat-of-mass-deaths-in-sawa-camp":3848};
	</script>
				<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/eritreahub.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://eritreahub.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'138410715',post:'3848',tz:'0',srv:'eritreahub.org'} ]);
	_stq.push([ 'clickTrackerInit', '138410715', '3848' ]);
</script>

</body>
</html>
