<!DOCTYPE html>
<html lang="en-US">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://eritreahub.org/xmlrpc.php">

<title>COVID19: Eritrean Christians appeal for the release of political prisoners - Eritrea Hub</title>

<!-- This site is optimized with the Yoast SEO plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="COVID19: Eritrean Christians appeal for the release of political prisoners - Eritrea Hub" />
<meta property="og:description" content="Eritrean Christian Charity Calls for Release of Prisoners of Conscience Amidst Fear of COVID19 Outbreak in the Country (London 29-03-2020)..." />
<meta property="og:url" content="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners" />
<meta property="og:site_name" content="Eritrea Hub" />
<meta property="article:tag" content="Coronavirus" />
<meta property="article:tag" content="COVID19" />
<meta property="article:tag" content="Political Prisoners" />
<meta property="article:tag" content="Release Eritrea" />
<meta property="article:tag" content="Rev. Dr Berhane Asmelash" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-03-29T13:58:10+00:00" />
<meta property="og:image" content="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=1280%2C853&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=1280%2C853&#038;ssl=1" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="853" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Eritrean Christian Charity Calls for Release of Prisoners of Conscience Amidst Fear of COVID19 Outbreak in the Country (London 29-03-2020)..." />
<meta name="twitter:title" content="COVID19: Eritrean Christians appeal for the release of political prisoners - Eritrea Hub" />
<meta name="twitter:image" content="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=1280%2C853&#038;ssl=1" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://eritreahub.org/#website","url":"https://eritreahub.org/","name":"Eritrea Hub","inLanguage":"en-US","description":"Information about Eritrea and the Horn of Africa","potentialAction":{"@type":"SearchAction","target":"https://eritreahub.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=1280%2C853&ssl=1","width":1280,"height":853},{"@type":"WebPage","@id":"https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners#webpage","url":"https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners","name":"COVID19: Eritrean Christians appeal for the release of political prisoners - Eritrea Hub","isPartOf":{"@id":"https://eritreahub.org/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners#primaryimage"},"datePublished":"2020-03-29T13:58:10+00:00","dateModified":"2020-03-29T13:58:10+00:00","author":{"@id":"https://eritreahub.org/#/schema/person/f8aa467e7efa6ad219dee345cc901ee5"}},{"@type":["Person"],"@id":"https://eritreahub.org/#/schema/person/f8aa467e7efa6ad219dee345cc901ee5","name":"Eritrea Hub","image":{"@type":"ImageObject","@id":"https://eritreahub.org/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/f500be2fede3974a790a653d590103bc?s=96&d=mm&r=g","caption":"Eritrea Hub"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; Feed" href="https://eritreahub.org/feed" />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; Comments Feed" href="https://eritreahub.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Eritrea Hub &raquo; COVID19: Eritrean Christians appeal for the release of political prisoners Comments Feed" href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/eritreahub.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='poseidon-custom-fonts-css'  href='https://eritreahub.org/wp-content/themes/poseidon/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://eritreahub.org/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://eritreahub.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='poseidon-stylesheet-css'  href='https://eritreahub.org/wp-content/themes/poseidon/style.css?ver=1.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://eritreahub.org/wp-content/themes/poseidon/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://eritreahub.org/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/navigation.js?ver=20170127'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/themes/poseidon/assets/js/sticky-header.js?ver=20170203'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<link rel='https://api.w.org/' href='https://eritreahub.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://eritreahub.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://eritreahub.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p9mKWT-Zz' />
<link rel="alternate" type="application/json+oembed" href="https://eritreahub.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feritreahub.org%2Fcovid19-eritrean-christians-appeal-for-the-release-of-political-prisoners" />
<link rel="alternate" type="text/xml+oembed" href="https://eritreahub.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feritreahub.org%2Fcovid19-eritrean-christians-appeal-for-the-release-of-political-prisoners&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.
Click the help icon above to learn more.
*/

p.site-description {}

@media only screen  and (max-width : 1224px) {
p.site-description {max-width:12em;}
}			</style>
		</head>

<body class="post-template-default single single-post postid-3817 single-format-standard wp-embed-responsive">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="https://eritreahub.org/" rel="home">Eritrea Hub</a></p>

							
			<p class="site-description">Information about Eritrea and the Horn of Africa</p>

		
				</div><!-- .site-branding -->

				<nav id="main-navigation" class="primary-navigation navigation clearfix" role="navigation">
					<ul id="menu-primary-nav" class="main-navigation-menu"><li id="menu-item-181" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181"><a href="https://eritreahub.org/category/news">News</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31"><a href="https://eritreahub.org/category/research-information">Research &#038; information</a>
<ul class="sub-menu">
	<li id="menu-item-87" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87"><a href="https://eritreahub.org/category/research-information/eu">EU</a></li>
	<li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88"><a href="https://eritreahub.org/category/research-information/africa">Africa</a></li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://eritreahub.org/category/maps-photography">Maps &#038; photography</a></li>
<li id="menu-item-53" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53"><a href="https://eritreahub.org/category/immigration-refugees">Immigration &#038; refugees</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://eritreahub.org/contact">Contact</a></li>
</ul>				</nav><!-- #main-navigation -->

			</div><!-- .header-main -->

		</header><!-- #masthead -->

		
		
		
		<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-3817" class="post-3817 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-coronavirus tag-covid19 tag-political-prisoners tag-release-eritrea tag-rev-dr-berhane-asmelash">

	
	<header class="entry-header">

		<h1 class="entry-title">COVID19: Eritrean Christians appeal for the release of political prisoners</h1>
		<div class="entry-meta"><span class="meta-date"><a href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners" title="1:58 pm" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-29T13:58:10+00:00">March 29, 2020</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://eritreahub.org/author/eritreahub" title="View all posts by Eritrea Hub" rel="author">Eritrea Hub</a></span></span><span class="meta-category"> <a href="https://eritreahub.org/category/news" rel="category tag">News</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<h3>Eritrean Christian Charity Calls for Release of Prisoners of Conscience Amidst Fear of COVID19 Outbreak in the Country</h3>
<p>(London 29-03-2020)</p>
<p><img data-attachment-id="3818" data-permalink="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners/dr-berhane-asmelash-praying-at-a-church-in-a-refugee-camp-in-ethiopia" data-orig-file="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=1280%2C853&amp;ssl=1" data-orig-size="1280,853" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1585489097&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Dr Berhane Asmelash praying at a church in a refugee camp in Ethiopia&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Dr Berhane Asmelash praying at a church in a refugee camp in Ethiopia" data-image-description="" data-medium-file="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?fit=840%2C559&amp;ssl=1" class="alignnone size-full wp-image-3818" src="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=840%2C560&#038;ssl=1" alt="Dr Berhane Asmelash praying at a church in a refugee camp in Ethiopia" width="840" height="560" srcset="https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?w=1280&amp;ssl=1 1280w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=1024%2C682&amp;ssl=1 1024w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=840%2C560&amp;ssl=1 840w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=120%2C80&amp;ssl=1 120w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=360%2C240&amp;ssl=1 360w, https://i0.wp.com/eritreahub.org/wp-content/uploads/2020/03/Dr-Berhane-Asmelash-praying-at-a-church-in-a-refugee-camp-in-Ethiopia.jpg?resize=600%2C400&amp;ssl=1 600w" sizes="(max-width: 840px) 100vw, 840px" data-recalc-dims="1" />Eritrean human rights charity, <em>Release Eritrea</em>, calls on the government of Eritrea to release all prisoners of conscience including those incarcerated for their faith in various prisons throughout the country, amidst fear of COVID19 outbreak. The charity has received information regarding the harrowing condition in detention centres where hundreds of people languish after they were detained because of their religious belief.  Prisoners are held in facilities that are not fit for human beings including shipment containers and make shift camps in deserted deserts, there is no medical care or basic toilets provided, many die of treatable illnesses.</p>
<p>The government of Eritrea has routinely harasses, imprisoned and regularly abused thousands of Eritrean Christians from minority church groups in the country on the count of their faith since the country’s independence. The situation was institutionalised when the regime outlawed the churches and begun to arrest followers enmas in May 2002, in the years that followed thousands have faced extreme persecution and many of them left the country at every opportunity they got, becoming victims of human trafficking and precarious journeys out of the country.</p>
<p>Persecution is on-going and infact 2019 saw the worst records of arrests with hundreds being incarcerated in the space of the few months after Eritrea struck a peace deal with Ethiopia.</p>
<p>Information received by the Charity shows that, in just three months in 2019, 239 people were detained in 4 prison camps across the country.  One prison in Mai-Temenay, on the outskirts of Asmara received 127 prisoners, while in Keren there were 43 arrests in the same period. Another prison in Asmara, in an area known as Godaif had 40 prisoners and a prison in Dkemhare had 24.</p>
<p>Currently it is estimated that there are some 600 prisoners in various prison including the ones mentioned above as well as the following across the country Mai –sirwa prison holds the largest numbers comprising of 72 women and 85 men, followed by the prison island in Dahlak where there is a desert camp with 15 female and 27 male prisoners. Hashferay camp has 8 women and 12 men and Adi Abeyto near the Capital holds 3 women and 12 men prisoners. Keren, Ala and Medefera have a handful male prisoners (less than five each) and Metkel Abyet has 3 female prisoners.  Inside Asmara there are long term- prisoners totalling just over 20 some of them have been in prison since 2004. In addition it is estimated there are a further 200 across various military contingents.</p>
<p>Over the years many have died due to illnesses, malnutrition and torture; given that these people have never been charged with crime, Release Eritrea calls for their immediate and unconditional release, pertinently at this time when their living conditions and malnutrition and various untreated illnesses could put them in unimaginable danger in the event of a COVID19 outbreak in the county.</p>
<p>Rev. Dr Berhane Asmelash director of Release Eritrea said ‘ I have always been concerned regarding the prisoners’ health given the over crowded conditions and severe malnutrition. I have spoken to many who escaped those prisons in refugee camps in Ethiopia and the situation is unimaginably difficult, there is no medical care whatsoever, there is no way anyone would survive a viral outbreak such as COVID19 in that condition. I would like to call for release of all prisoners of conscience. I am personally shaken by the report received by Release Eritrea f on the situation of Christian prisoners; we call for their immediate and unconditional release. Their continued incarceration is illegal and unjust and in the current situation totally inhumane’</p>
<p>Eritrea has last week confirmed the first six cases of COVID19 patients and is currently taking steps to control the spread of the disease. Other countries including neighbouring Ethiopia have taken the unprecedented step of releasing thousands of prisoners fearing  the potential implication of COVID19 outbreak.</p>
<p>Release Eritrea is a UK registered human rights charity that advocates for freedom religious worship in Eritrea.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-3817" class="share-twitter sd-button share-icon" href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-3817" class="share-facebook sd-button share-icon" href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="https://eritreahub.org/tag/coronavirus" rel="tag">Coronavirus</a><a href="https://eritreahub.org/tag/covid19" rel="tag">COVID19</a><a href="https://eritreahub.org/tag/political-prisoners" rel="tag">Political Prisoners</a><a href="https://eritreahub.org/tag/release-eritrea" rel="tag">Release Eritrea</a><a href="https://eritreahub.org/tag/rev-dr-berhane-asmelash" rel="tag">Rev. Dr Berhane Asmelash</a>				</span>
			</div><!-- .entry-tags -->

						
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://eritreahub.org/urgent-ethiopia-adopts-new-criteria-excluding-eritrean-refugees" rel="prev"><span class="screen-reader-text">Previous Post:</span>URGENT: Ethiopia adopts new criteria excluding Eritrean refugees</a></div><div class="nav-next"><a href="https://eritreahub.org/prime-minister-abiy-ahmed-if-covid-19-is-not-beaten-in-africa-it-will-return-to-haunt-us-all" rel="next"><span class="screen-reader-text">Next Post:</span>Prime Minister Abiy Ahmed: &#8220;If Covid-19 is not beaten in Africa it will return to haunt us all&#8221;</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://eritreahub.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3817' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f2e5b27506" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="31"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
		
		</main><!-- #main -->
	</section><!-- #primary -->
	
	
	<section id="secondary" class="sidebar widget-area clearfix" role="complementary">

		<aside id="categories-4" class="widget widget_categories clearfix"><div class="widget-header"><h3 class="widget-title">Categories</h3></div>		<ul>
				<li class="cat-item cat-item-244"><a href="https://eritreahub.org/category/ethiopia">Ethiopia</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://eritreahub.org/category/immigration-refugees">Immigration &amp; refugees</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://eritreahub.org/category/judicial-rulings">Judicial rulings</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://eritreahub.org/category/maps-photography">Maps &amp; photography</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://eritreahub.org/category/news">News</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://eritreahub.org/category/reports">Reports</a>
<ul class='children'>
	<li class="cat-item cat-item-38"><a href="https://eritreahub.org/category/reports/amnesty-international">Amnesty International</a>
</li>
	<li class="cat-item cat-item-577"><a href="https://eritreahub.org/category/reports/eritrea-focus">Eritrea Focus</a>
</li>
	<li class="cat-item cat-item-599"><a href="https://eritreahub.org/category/reports/ethiopia-insight">Ethiopia Insight</a>
</li>
	<li class="cat-item cat-item-237"><a href="https://eritreahub.org/category/reports/human-rights-watch">Human Rights Watch</a>
</li>
	<li class="cat-item cat-item-42"><a href="https://eritreahub.org/category/reports/institute-of-security-studies">Institute of Security Studies</a>
</li>
	<li class="cat-item cat-item-315"><a href="https://eritreahub.org/category/reports/parties">Parties</a>
</li>
	<li class="cat-item cat-item-86"><a href="https://eritreahub.org/category/reports/regional-mixed-migration-secretariat">Regional Mixed Migration Secretariat</a>
</li>
	<li class="cat-item cat-item-678"><a href="https://eritreahub.org/category/reports/uk-all-party-parliamentary-group">UK All Party Parliamentary Group</a>
</li>
	<li class="cat-item cat-item-186"><a href="https://eritreahub.org/category/reports/un-ocha">UN Ocha</a>
</li>
	<li class="cat-item cat-item-710"><a href="https://eritreahub.org/category/reports/unhcr">UNHCR</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://eritreahub.org/category/reports/united-nations-human-rights-commission">United Nations Human Rights Commission</a>
</li>
	<li class="cat-item cat-item-25"><a href="https://eritreahub.org/category/reports/united-nations-monitoring-group">United Nations Monitoring Group</a>
</li>
	<li class="cat-item cat-item-665"><a href="https://eritreahub.org/category/reports/us-state-department">US State Department</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-2"><a href="https://eritreahub.org/category/research-information">Research &amp; information</a>
<ul class='children'>
	<li class="cat-item cat-item-14"><a href="https://eritreahub.org/category/research-information/africa">Africa</a>
</li>
	<li class="cat-item cat-item-197"><a href="https://eritreahub.org/category/research-information/eritrea">Eritrea</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://eritreahub.org/category/research-information/eu">EU</a>
</li>
	<li class="cat-item cat-item-230"><a href="https://eritreahub.org/category/research-information/horn-of-africa">Horn of Africa</a>
</li>
	<li class="cat-item cat-item-422"><a href="https://eritreahub.org/category/research-information/international-crisis-group">International Crisis Group</a>
</li>
	<li class="cat-item cat-item-190"><a href="https://eritreahub.org/category/research-information/other">Other</a>
</li>
	<li class="cat-item cat-item-111"><a href="https://eritreahub.org/category/research-information/sudan">Sudan</a>
</li>
	<li class="cat-item cat-item-319"><a href="https://eritreahub.org/category/research-information/un">UN</a>
</li>
	<li class="cat-item cat-item-85"><a href="https://eritreahub.org/category/research-information/world-bank">World Bank</a>
</li>
	<li class="cat-item cat-item-77"><a href="https://eritreahub.org/category/research-information/yemen">Yemen</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-8"><a href="https://eritreahub.org/category/top-news">Top news</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://eritreahub.org/category/uncategorized">Uncategorized</a>
</li>
		</ul>
			</aside><aside id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget clearfix"><div class="widget-header"><h3 class="widget-title">Follow Blog via Email</h3></div>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Click to follow this blog and receive notifications of new posts by email.</p>
</div><p>Join 22,747 other subscribers</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-3"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Follow                        </button>
                    </p>
				            </form>
		
</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries clearfix">		<div class="widget-header"><h3 class="widget-title">Recent Posts</h3></div>		<ul>
											<li>
					<a href="https://eritreahub.org/prime-minister-abiy-ahmed-if-covid-19-is-not-beaten-in-africa-it-will-return-to-haunt-us-all">Prime Minister Abiy Ahmed: &#8220;If Covid-19 is not beaten in Africa it will return to haunt us all&#8221;</a>
									</li>
											<li>
					<a href="https://eritreahub.org/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners" aria-current="page">COVID19: Eritrean Christians appeal for the release of political prisoners</a>
									</li>
											<li>
					<a href="https://eritreahub.org/urgent-ethiopia-adopts-new-criteria-excluding-eritrean-refugees">URGENT: Ethiopia adopts new criteria excluding Eritrean refugees</a>
									</li>
											<li>
					<a href="https://eritreahub.org/un-assistance-mission-in-somalia-unsom-mandate-renewal-on-monday">UN Assistance Mission in Somalia (UNSOM) Mandate Renewal on Monday</a>
									</li>
											<li>
					<a href="https://eritreahub.org/with-abiy-in-his-corner-isaias-eyes-tplf-knockout">With Abiy in his corner, Isaias eyes TPLF knockout</a>
									</li>
					</ul>
		</aside><aside id="search-3" class="widget widget_search clearfix"><div class="widget-header"><h3 class="widget-title">Search</h3></div>
<form role="search" method="get" class="search-form" action="https://eritreahub.org/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
</form>
</aside>
	</section><!-- #secondary -->

	

	</div><!-- #content -->

	
	<div id="footer" class="footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			
			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		WordPress Theme: Poseidon by <a href="https://themezee.com/" target="_blank" rel="nofollow">ThemeZee</a>.	</span>

				</div><!-- .site-info -->

		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->

	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/eritreahub.org\/covid19-eritrean-christians-appeal-for-the-release-of-political-prisoners":3817};
	</script>
				<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/eritreahub.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/eritreahub.org\/wp-admin\/admin-ajax.php","nonce":"d7966baac3","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/eritreahub.org\/wp-login.php?redirect_to=https%3A%2F%2Feritreahub.org%2Fcovid19-eritrean-christians-appeal-for-the-release-of-political-prisoners","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://eritreahub.org/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://eritreahub.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://eritreahub.org/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202013.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'138410715',post:'3817',tz:'0',srv:'eritreahub.org'} ]);
	_stq.push([ 'clickTrackerInit', '138410715', '3817' ]);
</script>

</body>
</html>
